Welcome to Cockpitbuilders.com. Please login or sign up.

January 19, 2022, 10:27:02 AM

Login with username, password and session length


Fly Elise-ng
16 Guests, 1 User
  • Total Members: 4067
  • Latest: carelvr
  • Total Posts: 58355
  • Total Topics: 7742
  • Online Today: 18
  • Online Ever: 582
  • (January 22, 2020, 08:44:01 AM)
Users Online
Users: 1
Guests: 16
Total: 17



Will Depart in...



Aileron & Elevator jump back to center

Started by ScottThePilot, June 05, 2019, 10:25:26 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.



Working on Full cockpit running Windows 7, FSX-SE, Project Magenta 737-800 and FSUIPC version 4.960.  Everything has been fine for years with all flight controls and brakes configured through FSUIPC.  All of a sudden when starting flight yesterday, when you move a flight control (ie. Ailerons), they will start to move but immediately jump back to center (not hold the input) and continue to flutter (small jitters).  Same for other controls.  This jump and jitter happen on the PM 737-800 and on any other plane we select.  We have done the following trouble shooting:

1. Checked FSX-SE to make sure their were no assignments for flight controls or any buttons that would interfere.

2. Checked our hardware in Windows directly and everything is seen and moves as expected.

3. Tried using just a keyboard to move flight controls with all our hardware unplugged.  No help.

4. Deleted the .ini file and let FSUIPC create new one and reassign.  No help.

What did work was to remove the FSUIPC4.dll file from modules folder and set up flight controls in FSX-SE.  With FSUIPC not loaded, flight controls using keyboard and our hardware worked as they should.  The moment we put the .dll back (so it loads) and delete the FSX assignments, jitter and flutter return when moving flight controls.  We conclude that our hardware is OK since it works with FSUIPC not loaded and Windows sees it moving correctly.

We don't believe it is an .ini problem since we let it create a new one (after deleting ours) and we still got same jitter and flutter.  Could the .dll have an issue?  What else do you think could be causing this "drop back to center and flutter"  I see the current version is 4.974 which is slightly newer.  But why all of a sudden since our registered (Thanks Peter) version has worked flawlessly for so long.   No hardware or software added between one night working perfect and the next morning messed up.

I will include our .ini file as it does have some (what I think are) duplicate entries under [Buttons] (TRIM) and [Axes] (Ailerons & Elevator).  Interesting that the Rudder seems to be fine.  Could dropping in the most current .dll file do the trick?  We didn't explore that today.

One additional thing is that the STAB Trim indication on the bottom right of the Upper EICAS bounces in the direction of switch movement on yoke but bounces back to full NU trim (10) on our scale.  Since there are setting in .ini file for this that also look duplicated, we assume this is related.

I know its a lot with hopefully enough detail but would appreciate any help..   

Pilot for 40+ years --- Software Coder for 40+ years -- Simmer For A Day!
Hummm.  Which do I love more...

Trevor Hale

June 06, 2019, 01:45:55 PM #1 Last Edit: June 06, 2019, 01:46:50 PM by Trevor Hale
Weather the axis assignments are set in FSX or not, In prepar3d there is a button to disable all controllers. If that exists in FSX (Been too long to remember) See if that helps.
Trevor Hale


Director of Operations
Worldflight Team USA



Thanks Trevor,

We have triple checked to make sure that nothing is interfering.  About the only thing we haven't physically looked at was the FSX Config file to see if something is stray in there.

By the way, now that I have seen video of what it does, I can describe better.  Lets say you pull the elevator back to some degree.  You can see from outside the airplane that the elevator does indeed move in up direction.  As you hold the yoke there, the elevator will slowly sink back down to neutral.

We also updated to latest FSUIPC just to make sure that was not a problem.  We then deleted the FSUIPC.INI file and let it create a new clean one.  Then we defined just ailerons for simplicity. Went into FSX again and let it reload and it still happens...

Completely stumped as are others...
Pilot for 40+ years --- Software Coder for 40+ years -- Simmer For A Day!
Hummm.  Which do I love more...


Back up your FSX.cfg and delete it. See what happens, i have had times when everything seems normal but a delete of cfg fixed it. I had FSUIPC do similar things.

Like the Website ?
Support Cockpitbuilders.com and Click Below to Donate