Welcome to Cockpitbuilders.com. Please login or sign up.

May 18, 2022, 05:40:22 AM

Login with username, password and session length

PROUDLY ENDORSING


Fly Elise-ng
15 Guests, 0 Users
Members
Stats
  • Total Posts: 58862
  • Total Topics: 7786
  • Online Today: 22
  • Online Ever: 582
  • (January 22, 2020, 08:44:01 AM)
Users Online
Users: 0
Guests: 15
Total: 15

COUNTDOWN TO WF2022


WORLDFLIGHT TEAM USA

Will Depart in...

Recent

Welcome

Rotary encoders question

Started by Reco, January 13, 2022, 04:15:40 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Reco

Happy New year all

I am rewiring my Bodnar board for my MD500e simulator.
I have the BU0836X, encoder software and  Rotary encoder CTS 288
I have wired the encoder to 1 and 2 set the config to 1:1

In the windows joystick calibration tool, it tells me that button 1 and 2 are working, so far so good
 
When I go into fsuipc and assign the encoder the button combination shows  0 and 1 when I turn the encoder
Is this correct? shouldn't fsuipc show 1 and 2
Some what confused

Regards

Rhys

RayS

If I recall, Windows enumerates joystick buttons starting at 1, and FSUIPC at 0.
Ray Sotkiewicz

iwik


Reco

Hi guys

Thank you for the reply. Does the encoder config software recognize that
It's still 1 and 2 even if fsuipc shows 0 and 1

Cheers

Rhys

RayS

Quote from: Reco on January 15, 2022, 08:44:24 AMHi guys

Thank you for the reply. Does the encoder config software recognize that
It's still 1 and 2 even if fsuipc shows 0 and 1

Cheers

Rhys

Only way is to try it out... :-)
Ray Sotkiewicz

Like the Website ?
Support Cockpitbuilders.com and Click Below to Donate